Search This Blog

Create a bootable usb stick from ISO file on Mac OS X

  1. Have your bootable .iso image file ready
  2. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight).
  3. Convert the .iso file to .img using the convert option of hdiutil e.g.,
    hdiutil convert -format UDRW -o ~/path/to/debian.img ~/path/to/debian.iso
    mv ~/path/to/debian.img.dmg ~/path/to/debian.img

    Note: OS X tends to put the .dmg ending on the output file automatically.
  4. Run
    diskutil list
    to get the current list of devices.
  5. Insert your usb stick.
  6. Run
    diskutil list
    again and determine the device node assigned to your flash media (e.g. /dev/disk2).
  7. Run
    diskutil unmountDisk /dev/diskN
    (Note:replace N with the disk number from the last command; in the previous example, N would be 2).
  8. Execute
    sudo dd if=/path/to/debian.img of=/dev/rdiskN bs=1m
    (replace /path/to/debian.img with the path where the image file is located).
    Note:Using /dev/rdisk instead of /dev/disk may be faster.
    If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M
    If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.
  9. Run
    diskutil eject /dev/diskN
    and remove your flash media when the command completes.
  10. Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.

No comments:

Post a Comment